Plugin type Exception (only) with latest version of SpecSharp, unable to compile now

Aug 18, 2010 at 7:56 PM

Hi

I installed the latest version of Spec Sharp binaries and got the following error. 

Error 6 Plugin type 'Microsoft.Boogie.BoogiePluginVisitor' threw exception 'Method not found: 'Microsoft.Boogie.TranslatedProgram Microsoft.Boogie.CilTranslator.TranslateAstToBoogie(System.Compiler.CompilationUnit, System.Compiler.Analyzer, System.Compiler.ErrorHandler)'.'.\nStack:    at Microsoft.Boogie.BoogiePluginVisitor.VisitCompilationUnit(CompilationUnit unit)   at System.Compiler.StandardVisitor.VisitCompilationUnitSnippet(CompilationUnitSnippet snippet) in C:\specsharp\SpecSharp\System.Compiler\StandardVisitor.cs:line 849   at System.Compiler.StandardVisitor.Visit(Node node) in C:\specsharp\SpecSharp\System.Compiler\StandardVisitor.cs:line 167   at Microsoft.SpecSharp.SpecSharpCompilation.RunPlugins(Node node, ErrorHandler errorHandler) in C:\specsharp\SpecSharp\Microsoft.SpecSharp\Compiler.cs:line 150 C:\Documents and Settings\My Documents\Visual Studio 2008\Projects\XMLSpecProj\XMLSpecProj\Transaction.ssc 1 1 XMLSpecProj

 

I am sort of hitting the wall now, because, i reinstalled my Visual Studio 2008, got latest Z3 verifier, got the latest version of SpecSharp .. registered the .dll's successfully .. but still getting the same error. 

Does anyone have any Idea about this error? I am not able to proceed at all as this isn't working. My project is not even compiling any more. It does not look like some kind of a logical error.

PLEASE HELP!

Thanks in advance.. 

 

 

 

 

 

 

Aug 20, 2010 at 6:52 PM
Edited Aug 20, 2010 at 7:13 PM

Is it that the following code in  Compiler class

 pluginVisitor.Visit(node); 

is failing to find the boogie plugin? 

Should i work with the Source Code instead of binaries? Would that solve the plugin exception i am running into ? 

I also tried the same thing (download and register latest specsharp binaries) on another machine afresh. But encountered the same problem. Is there any workaround?

Thanks

Ruchi

Aug 21, 2010 at 2:03 AM

Ok .. So i have resolved the issue stated above

Apparently, there are two downloads, i downloaded the july load, which throws the plugin exception. However, the August 5 version resolved the problem.

 

1.0.21125.0 - Aug 5 2009, Stable

 

THANKS!!