This project is read-only.

Unable to Create a spec project

May 10, 2011 at 3:32 AM

Hey So I followed the directions on http://specsharp.codeplex.com/wikipage?title=Binaries&referringTitle=Home. I tried to create/open a spec project and had no luck. When I try to create one, I find no projects for spec. When I try to open, it states cannot be opened because its project type (.sscproj) is not supported by this version of the application..   I then did some searching the forms (http://specsharp.codeplex.com/discussions/227607 and http://specsharp.codeplex.com/discussions/227607) and tried the suggestions.

 

VS 2010 Professional - 32-bit (got it from Dreamspark)

Windows 7 Professional 64-bit. 

Let me know if anything other information.

Thanks,

Brad

May 10, 2011 at 8:44 AM

Hi Brad,

which version of Spec# did you download? Have you tried out the nightly builds (Downloads ==> Planned ==> Nightly builds) yet? Please let me know if this solves the issue.

Best regards,

Valentin

May 10, 2011 at 2:01 PM
Edited May 10, 2011 at 2:01 PM

Ok I had downloaded the latest release one (Wed Oct 13 2010 at 2:00 AM). I am know able to create the projects and use it with the latest nightly build. However, when I downloaded the tutorial code (http://specsharp.codeplex.com/wikipage?title=Tutorial), I had converted it before spec# was installed to the VS 2010 project from 2008. I got the following error.

 
The 'Microsoft VisualStudio CodeTools PropertyPage Package' package did not load correctly.

 

The problem may have been caused by a configuration change or by the installation of another extension. You can get more information by running the application together with the /log parameter on the command line, and then examining the file '[my users path]AppData\Roaming\Microsoft\VisualStudio\10.0\ActivityLog.xml'.

I got this error when opening the project before I installed spec# and when converting a whole new tutorial I got the same error with spec# installed. Also from what I gather with this (http://specsharp.codeplex.com/discussions/227607), it should be fixed now.

Thanks,

 

Brad

May 11, 2011 at 9:56 AM

I've seen this error a few times and I believe that I was able to resolve it by cleaning and re-registering Spec#.

For opening and building the Spec# tutorial, the following worked for me: 1) Unzip the the project. 2) Open Tutorial.sln in VS 2010 and convert it.

Please let me know if that does not work on your machine.

Thanks,

Valentin